c# 版本的SDK 下载下来以后 可以直接引入到我的项目中吗?


#2

VS2017 改了项目结构。如果没法装 VS2017,那就用老版本吧。 https://github.com/jpush/jpush-api-csharp-client/tree/v1

根据 readme 说明使用


#3

(神一样) #4

我有VS2017
就是不知道到时候服务器上 支持部支持这个.net fk 4.5的 版本


#5

那你可以先用旧版呀


(神一样) #6

旧版是支持VS 2010 和 fk4.0 的 吗?


#7

是的,支持 Microsoft. NET Framework 4.0 (包括)以上版本。


(神一样) #8

旧版的使用起来跟新版一样方便吗?
会不会使用很麻烦?


#9

不麻烦,


新版本是为了支持这个重构过的

你跟着旧版本 readme 说明来就是了


(神一样) #10

这是VS2017 控制台应用程序调试 这个 'Newtonsoft.Json, dll 引用了 怎么还是有这个错误


#11

有添加 Newtonsoft.Json 依赖吗?是否版本过低


(神一样) #12

添加了 就是添加的 net45 里面的 Newtonsoft.Json.dll
因为 net45 里面就2 个dll


(神一样) #13

旧版本的和V3新版本的参数解释说明是一样的吧?
还是说旧版本需要参考V2


#14

用的也是 V3 的


(神一样) #15

OK 谢谢大神


(神一样) #16

用旧版本 跟手机app 集成的SDK 没什么关系吧 这两者应该不影响吧


#17

没有关系的。


(神一样) #18

你好在吗?

这个消息安卓手机那边怎么收不到呢?


#19


排查


(神一样) #20

你好 请教一下
你们极光推送 是一次可以推多个用户 但是推送的消息内容必须是一样的吗?
那这种场景推送多个用户但是每个用户推送的内容不一样
怎么设置 参数?


#21

这种情况,分开调 API 推送,推送一次,内容是一样的。
调用一次 API 最多做到 Android 和 iOS 的不一样