关于Get sdk version fail![获取sdk版本失败!]问题

android
jpush
标签: #<Tag:0x00007fb83f5d6048> #<Tag:0x00007fb83f5d5f08>

(风荡鸢翎) #1

您好, 我在使用极光推送时候遇到了问题
安卓上会报错提示Java.lang.UnsatisfiedLinkError以及Get sdk version fail![获取sdk版本失败!]

我这边是使用Eclispe的, 项目配置截图如下

案例的libs中我看到了是需要有诸如arm64-v8a, armeabi-v7a, mips等有libjcore118.so动态链接库的文件夹, 但是由于我使用cocos2dx, 在编译时会将libs中的动态链接库全部删除后在生成。。。:joy:

所以我也只在网上找到方法把libjcore118.so生成到armeabi中而已, 别的不知道改怎么放入并且编译中不被删除。。

请问这个和我遇到的问题有关吗, 还是说我别的地方配置错了,求帮助


#2

你可以看一下这个插件

这个报错看:


(风荡鸢翎) #3

谢谢大佬, 虽然最后没有采用上述方案。
我研究了下主要解决cocos2dx 引入三方so 的问题就可以了
最后是根据这个方案成功接入了推送
https://www.2cto.com/kf/201408/329559.html