iOS收不到通知,从昨天开始发现

jpush
ios
收不到消息
标签: #<Tag:0x00007fb846d68548> #<Tag:0x00007fb846d68340> #<Tag:0x00007fb846d68048>

(举举手) #1

测试环境,后台发通知 某些设备收不到
Message ID 4045838670

测试发现收不到的registrationID:1.121c83f76016a93dfeb 2. 141fe1da9e99f9c5cff 3. 1a1018970a940c3dc01


#2

这几个 registrationID并没有绑定你推送的这个别名,请你检查,自己也可以在服务端去查绑定情况


(举举手) #4

我重新跑了这几个机子,都走了设置tags的回调方法,显示tags设置没问题,Message ID 394009375这条可是还有下面几个没收到:1. 121c83f76016a98e6db 2. 18171adc033f6e10887 3. 101d855909755742da4

你说在后台看是否设置了tags 具体的位置在哪里查


#5

1、看我给你贴的链接,调用API查
2、走了方法,是否有返回callback为0?将日志贴出来。


(举举手) #7

现在我测试了,发现有问题。我设置了标签不该收到的收到了,该收到的却没有收到 Message ID 1227420891这个消息

13165ffa4e076ae5b07 设备和 171976fa8ab2ef71bb2应该收到却没有收到消息,

18171adc033f6028277这个设备不该收到,却收到了推送


#8

请对比你设置或者置空的时间与你实际推送的时间差
消息推送时间:2017-03-10 16:15:04


(举举手) #9

这个能在哪里查到,我这边主观看的话大概是4分钟


#10

额,你看你设置别名的log的时间 是在推送之后还是在之前额。
在你设置之前就推送了的,自然不能按照你此次设置的情况来算,你可以现在在测试看是否有这种情况发生


(举举手) #11

我是使用你刚才给我的api查的设备的itag 没问题的,查到的tag是我设置的tag,但是推送消息发过来,却有不该有的结果,你说的设置tag的log时间 就是设置tag的回调的时间吧。那个肯定是在推送之前的,都隔了好几分钟


#12

给我提供你的log,以及你现在推送是否还有问题。


(举举手) #13

你说的log 是+ (void)setTags:(NSSet *)tags
alias:(NSString *)alias
fetchCompletionHandle:(void (^)(int iResCode, NSSet *iTags, NSString *iAlias))completionHandler;这个方法的回调吗


#14

这里说明一下:
极光服务器的tag或者标签的信息完全来自你们的设置

所以基本上,在推送该消息后出现你预期不一致的情况,一般都是你们设置不成功或者成功后又有改变导致

所以如果你不纠结于该条消息的话,可以现在 看你的日志,在设置别名/标签成功后,再没有第二次改变了,现在测试,是否有问题。

如果你要找出原因,那么就得看2017-03-10 16:15:04之前的日志里,对于别名和标签的设置情况。


(举举手) #15

你说的日志应该从哪儿看,可以给我个入口吗


#16

(举举手) #17

tks 我先看看