集成其他的SDK后极光SDK报错


(自水漂零) #1

第一次在极光社区发东西,不太会玩,就借用一下这个帖子的位置了:joy:


项目是之前就集成好了极光推送,然后现在因为需要,我又集成了别的SDK,瞎折腾之后没报错了,但是app运行出bug了,发现日志报JPush的错。 这个该咋搞啊


获取sdk版本失败,急求啊各位大神们,找不到原因了
#2

根据这个 排查一下


(自水漂零) #3


在集成另一个SDK之前,极光是集成好的,没啥问题,所以根据那个啥问题合集查不出来问题,都是对得上的。另一个SDK是通过依赖module添加的。


#4

1、出现这样的报错,一般都是总结上的问题,你可再仔细对照一下。so加全。

2、注意添加一下混淆
https://docs.jiguang.cn/jpush/client/Android/android_guide/#_6