使用第三方插件出现验证弹窗

标签: #<Tag:0x00007f65996be6e8>

使用插件jpush-phonegap-plugin(版本:3.6.4)集成后,iOS应用(iOS系统10.x、11.X,12.X)都会出现Cannot Verify Server Identity弹窗,如图片所示,点击trust后,后续还会不定时出现,消息推送正常,求帮助!!!!
1563343072807 WeChat8c3766426aa007ad1ba8123ac80ae82e

请提供一下你的客户端日志,看最终集成的极光 SDK 的版本是多少

说明下你测试到的手机机型和对应的系统

您好,目前我在极光初始化后添加了日志开启的代码,但打包出来的生产环境ipa安装运行并推送消息后,在沙盒里面并没有日志记录文件啊,xcode打包的时候edit scheme 也是debug,arguments也没有配置什么变量 1563417441350
测试的机型:xs max 12.1.4 5s 10.3.1

你这边集成插件后,将涉及到 BundleID 和证书的地方,都替换成你自己的,注意看看是否可能关联到了极光的证书(是否可能用了极光的 demo里面的证书)

SDK 本身并不涉及要配极光证书相关的。

谢谢,我检查下,有问题再请教!目前推送都是正常的,证书应该没问题,但是我还是检查下你说的这点

因为理论上开发者的项目里面不会有极光的证书,弹出这个提示对你 App 的用户体验也不好,所以你这边检查下是不是不小心把极光的证书加进去了。

嗯嗯,那我可以删除这个目录结构下无用的文件示例吗?这是默认安装后的插件结构:比如删除example、ionic ,hooks可以删除吗1563434396488

除了下图结构里面的,其他的都可以删

好的。谢谢!只有这样先试试

你现在是否还有观测到这样的问题?

您好!目前还是出现了这种提示,只插件目录也只剩下了有用的文件,不知道如何下手了:joy::joy:

将你的目录完全展开看一下,再搜索一下 jpush.cn 看看

我搜索了ionic工程和打包出来iOS工程,都没有这个

跟jcore-ios-1.2.6.a这个有关系吗

没关系,这个是必要的库

插件应该怎么集成极光的日志呢,我看文档都是说的原生sdk

不知道能不能从日志看出什么,主要现在推送功能都是正常的

你可以把你那边的项目发来看看吗?目前也没其他集成这个插件的用户反馈有这种现象。

iOS的日志不知道你用的工具有没有输出,可以用xcode 运行看看