IOS 低版本收不到推送

标签: #<Tag:0x00007f658aafee38>

IOS 低版本收不到消息,但是高版本的可以,有registerID,用的jpush-react-native,这是什么原因,是不支持低版本了么

支持,没有取到 token的看下这个吧

我之前看过这篇文章了,都试过了,没问题,而且其他手机都可以收到推送,我去开发者中心删除然后重新添加了,以后没啥用

你将这个手机集成的日志给一下,是用的最新版本的SDK吗

这个么? ----- login result -----

uid:31022828380

registrationID:1a1018970ac70b111e1

idc:1

sdk版本是3.1.2 应该是最新的 react-native版本是0.50,有点低了,jpush-react-native版本是2.5.3

55C25B83-C021-485C-8E53-227F80C175C9

3.1.2 是18 年的版本了,最新的是 JPush iOS SDK v3.2.2

最新的插件里原生的 SDK 已经升级到了 3.2.2 ,你可以根据最新的说明再集成一下最新版本

目前查询你这个registrationID确实没有上报 token。
针对取不到 token 的问题,目前只有上面所说的排查方案,文档里面的这个看了没有
http://docs.jiguang.cn/jpush/client/iOS/ios_faq/#not-get-devicetoken-yet-maybe-your-certificate-not-configured-apns

看过这篇文档,没有开启apn,然后上述两个方法都没进入,最后这个设备与 apple 的网络连通性问题,也换过网段,好像也没成功