SDK推送的向下兼容的版本是多少的,这些方法4.4的都不能调用

jpush
标签: #<Tag:0x00007fb837fe4060>

(Lefu) #1


#2

could not find class 'android.os

你说的是 Android 客户端SDK吗?

这里看到的报错没有看到极光相关的


(Lefu) #3

是的,在4.4的系统收不到广播,在5.1可以收到


#4

麻烦看一下集成日志,是否有成功,看一下JPush相关的日志,是否有报错。

成功集成而收不到消息请提供msgid和设备的registrationID


(Lefu) #5

log.txt (50.7 KB)
log日记已经上传了


#6

目前SDK支持Android 2.3或以上版本的手机系统。富媒体信息流功能则需Android3.0或以上版本的系统。

对于4.4都是没有问题的,你给的日志里面我搜索了一下,找到一个msgid 493565151,是富媒体消息,而且既然log有了,那自然是收到了的。

如果有消息疑问,你在客户端获取一下registrationID给我,再提供测试的消息的msgid。


(Lefu) #7

这里的确收到了,但在项目中的静态广播收不到广播,log在显示中是不是有个网络框架的异常


(Lefu) #8

正常log是这样的才对呀,registrationID:1104a897929bf90e36b,测试的消息的msgid:3493420768,麻烦帮忙查一下


#9

如果你说的是 这个报错:
http post IOException error:com.android.org.bouncycastle.jce.exception.
可看:
http://www.cnblogs.com/wanqieddy/p/4864730.html

另:你的日志里面都打印了msgid,自然是收到的,我这边查也是收到的,你那边认为的出现的问题是什么?
没有展示给你?还是怎样?

富媒体消息 是需要将压缩包res中的资源放到项目的对应文件夹,并按照示例AndroidManifest配置组件的

按照目前的情况:你能获取到registrationID说明集成成功,消息也能收到。已经是很正常的状况了。

有问题的机型是?
你在4.4.上跑一下我们的demo看下呢。