集成JPush后JMessage不能用了

ios
标签: #<Tag:0x00007f83e11753d8>

#1

大佬,我是先集成的JMessage,使用后发现收不到通知,然后我又把JPUSH集成到项目中了。因为JMessage是手动集成的,JPUSH是用cocoapods集成的,项目中有俩个jcore-ios-2.0.0.a,我就把手动集成的jcore-ios-2.0.0.a给删除了,现在JMessage一直说我用户未登陆,是不是因为删除jcore-ios-2.0.0.a这个的原因。通过cocoapods集成的是libjcore-ios-2.0.2.a这个版本,应该高版本可以兼容低版本啊。帮忙分析一下


#2

1、JCore 保留一个高版本即可

2、先看日志,JPush和JMessage是否都有集成成功,其次网站的证书配了没有?


3、JMessage 自带有通知提醒不需要 JPush,没有提醒的情况下检查