jpush和jmessage的Flutter插件在flutter1.6.x以上版本上崩溃(安卓)

标签: #<Tag:0x00007f658adcd600> #<Tag:0x00007f658adcd420> #<Tag:0x00007f658adcd218> #<Tag:0x00007f658adcd010> #<Tag:0x00007f658adccca0>


在安卓设备上,如图,在设置alias等操作,但凡有callback回调操作的地方,都会崩溃,原因是flutter1.6.0+版本之后修改了机制,要求相关操作不得在子线程,而必须在ui主线程中完成。

另外jpush_flutter 0.0.11和jmessage_flutter 0.0.16所引用的原生sdk版本过低,目前发现部分问题,
比如安卓上面的getConversations不能实时返回,必须间隔3秒后,重复调用,才能获得会话列表;
比如安卓上的getHistoryMessages,在超过一段时间后,再次调用,由于云端数据已经清空,而原生java代码未作保护,引起空指针错误

请问这些问题是否在最新的jpush和jcore中解决?如果解决的话,什么时候可以更新jpush_flutter和jmessage_flutter?

问题已反馈给研发。

请问这个要求有官方说明吗?

你目前使用的 Flutter 版本是?从何处取得该版本信息?

目前我线上app版本已经降级到flutter1.5.4-hotfix.2也就是stable分支,其他3个分支变动较快,目前应该是1.7.0+的版本了,回调机制的话官方似乎没有一个完整的文档说明,但可以参考https://github.com/flutter/flutter/issues。
另外版本太老的问题,可以升级一下,包括web端的im sdk,2018年1月到现在没更新过

我们用的是flutter 稳定分支 stable的代码 1.5.4,1.6.0 还并非稳定版本,非稳定版本的暂时不适配

但是现在flutter插件跟android和ios插件版本有点差距,有蛮多问题,什么时候可以升级flutter sdk呢

你说的是插件 未和最新的极光原生 SDK 版本适配吗?

是的,flutter插件未与最新原生sdk版本匹配,而且是差了个大版本

另外,现在flutter的stable分支直接升级到了1.7.8+hotfix.2版本,你们的插件已经无法使用了,之前提醒过让尽早适配1.6.0+,你们开发还说只适配stable分支,现在直接到了1.7.8版本,是不是工作量更大了?

java.lang.RuntimeException: Methods marked with @UiThread must be executed on the main thread. Current thread: MessageReceiver

jpush_flutter: “^0.0.11”
jmessage_flutter: “^0.0.17”

android崩溃

请问你是在做什么操作的时候crash 的?

描述下具体的情况

我们刚刚升级到了 Flutter 最新版本用插件的时候,没有发现你说的异常

setAlias
getConversations

只在安卓上崩溃

已反馈给研发

发现同样问题,在稳定版v1.7.8+hotfix.3-stable android崩溃

请问啥时候能更新呢,现在也等着更新 flutter 版本

发现同样问题,在稳定版v1.7.8+hotfix.3-stable android崩溃